re = /(?=(?P<char>.))(?P=char){4,}/mi
str = 'ITS TIMEEEEEEEEE FOR ANNEW TRAILER FINALLY WE ARE GETTING SOMETHING'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end