const regex = /(?:((?!www\.)\b\w+)\.)?site\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?!www\\.)\\b\\w+)\\.)?site\\.com', 'gm')
const str = `https://www.prefix.site.com
https://www.site.com
https://prefix.site.com
https://site.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}