re = /(?:((?!www\.)\b\w+)\.)?site\.com/m
str = 'https://www.prefix.site.com
https://www.site.com
https://prefix.site.com
https://site.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end