re = /(?<=DASH_)[0-9]*/
str = 'https://v.redd.it/fk2a85c7qac71/DASH_360.mp4?source=fallback'
subst = 'audio'
result = str.sub(re, subst)
# Print the result of the substitution
puts result