package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\btrim(\((?:[^()]++|(?1))*\))`)
var str = `trim(p) trim(str(p_name))`
var substitution = "ltrim(r\g<0>)"
fmt.Println(re.ReplaceAllString(str, substitution))
}