$re = '/\btrim(\((?:[^()]++|(?1))*\))/m';
$str = 'trim(p) trim(str(p_name))';
$subst = "ltrim(r\g<0>)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;