import re
regex = re.compile(r"((?<=<q>)(.|\n|\s)*?(?=</q>))|((?<=<t>)(.|\n|\s)*?(?=</t>))", flags=re.MULTILINE)
test_str = ("<q>123e42wfd</q>\n\n"
"<p> Праздничную иллюминацию в Липецке прежде традиционно отключали 15 января. Однако в этом году она будет работать до конца месяца, соответственно дольше обычного жители областного центра смогут любоваться световыми арт-объектами и нарядными новогодними елками. \n\n\n\n"
"Такое решение принял глава города Сергей Иванов.Как сообщил председатель департамента дорожного хозяйства и благоустройства Алексей Бахтин, идея навеяна самой нынешней зимой. Яркие краски светового оформления города подчеркнут красоту заснеженных улиц и продлят праздничное настроение липчанам. </p> \n\n"
"<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию здоровья. Недавно он перенес тяжелую операцию на сердце и решил уйти с должности на пенсию, - прокомментировал GOROD48 циркулирующие слухи об отставке управделами мэрии глава Липецка Сергей Иванов. </t>\n\n"
"(?<=<title>)(.*)(?=</title>)\n\n\n"
"<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию </t>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")