# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$"
test_str = ("!123qwe@\n"
"asd32132\n"
"zxc123\n"
"xzc\n"
"123\n"
"####\n"
"xccx\n"
"cxqwe123qwesdaasd\n"
"ASD321asd\n"
"123123123123123\n"
"!123qwe@\n"
"!123QwE@\n"
"!123123\n"
"!123 123\n"
"!123123 \n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.