re = /(?=^.{8,}$)(?=[!@#%?&*!\\|]{1,})(?=^\S*$).*$/m
str = '!123qwe@
asd32132
zxc123
xzc
123
####
xccx
cxqwe123qwesdaasd
ASD321asd
123123123123123
!123qwe@
!123QwE@
!123123
!123 123
!123123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end