using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-*\d*.?\d+";
string input = @"Line: GB -13.5
O/U: 51.5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}