$re = '/-*\d*.?\d+/m';
$str = 'Line: GB -13.5
O/U: 51.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);