$re = '/[\D\b]50\D/m';
$str = '50.txt
GSD Crash - 50.wav
150(some text).png
1500(some text).png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);