re = /[\D\b]50\D/m
str = '50.txt
GSD Crash - 50.wav
150(some text).png
1500(some text).png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end