$re = '/[A-Z0-9._%-]+@[A-Z0-9-]+\.[A-Z]{2,4}/i';
$str = 'Email: regex_cpp@net.br Valid
Email: regex_cpp@terra.com.br Valid
Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)
Email: regex_cpp@hotmail.com Valid
Email: regex_cpp@yahoo.com.br Valid
Email: regex_cpp@gmail.com Valid
Email: regex_cpp@bol.com.br Valid
Email: regex.cpp@bol.com Valid
Email: reg_ex.cpp@bol.com Valid
Email: reg_ex.cpp@org.br Valid
Email: reg_ex.cpp@net.org.br Valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);