import re
regex = re.compile(r"[A-Z0-9._%-]+@[A-Z0-9-]+\.[A-Z]{2,4}", flags=re.IGNORECASE)
test_str = ("Email: regex_cpp@net.br Valid\n"
"Email: regex_cpp@terra.com.br Valid\n"
"Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)\n"
"Email: regex_cpp@hotmail.com Valid\n"
"Email: regex_cpp@yahoo.com.br Valid\n"
"Email: regex_cpp@gmail.com Valid\n"
"Email: regex_cpp@bol.com.br Valid\n"
"Email: regex.cpp@bol.com Valid\n"
"Email: reg_ex.cpp@bol.com Valid\n"
"Email: reg_ex.cpp@org.br Valid\n"
"Email: reg_ex.cpp@net.org.br Valid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")