package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[A-Z0-9._%-]+@[A-Z0-9-]+(\.[A-Z]{2,4}){1,2}`)
var str = `Email: regex_cpp@net.br Valid
Email: regex_cpp@terra.com.br Valid
Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)
Email: regex_cpp@hotmail.com Valid
Email: regex_cpp@yahoo.com.br Valid
Email: regex_cpp@gmail.com Valid
Email: regex_cpp@bol.com.br Valid
Email: regex.cpp@bol.com Valid
Email: reg_ex.cpp@bol.com Valid
Email: reg_ex.cpp@org.br Valid
Email: reg_ex.cpp@net.org.br Valid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}