# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z0-9._%-]+@[A-Z0-9-]+(\.[A-Z]{2,4}){1,2}"
test_str = ("Email: regex_cpp@net.br Valid\n"
"Email: regex_cpp@terra.com.br Valid\n"
"Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)\n"
"Email: regex_cpp@hotmail.com Valid\n"
"Email: regex_cpp@yahoo.com.br Valid\n"
"Email: regex_cpp@gmail.com Valid\n"
"Email: regex_cpp@bol.com.br Valid\n"
"Email: regex.cpp@bol.com Valid\n"
"Email: reg_ex.cpp@bol.com Valid\n"
"Email: reg_ex.cpp@org.br Valid\n"
"Email: reg_ex.cpp@net.org.br Valid")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.