const regex = /^(?=.{3,50})\p{L}*(\s\p{L}*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{3,50})\\p{L}*(\\s\\p{L}*)?$', 'gm')
const str = `I need a RegEx to match the following condition:
1 or 2 words
Total minimum length is 3
Total maximum length is 50
Accept accented characters
No numbers is a plus
Examples of accepted strings:
Karmen Garcia
João Pedro
Vitor
maxiliamum LóPezz
Nadál
loriPsium PsisVõèrbizbbbbbbbbbb
Examples of non accepted string:
Jony Cam Vanis
9lucas P.us-kas1 Li1
What I tried:
^(?!.*?\\s{2})[A-Za-z ]{3,50}\$
^([a-zA-Z][a-zA-Z]){3,50}\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}