# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{3,50})\p{L}*(\s\p{L}*)?$"
test_str = ("I need a RegEx to match the following condition:\n\n"
"1 or 2 words\n"
"Total minimum length is 3\n"
"Total maximum length is 50\n"
"Accept accented characters\n"
"No numbers is a plus\n"
"Examples of accepted strings:\n\n"
"Karmen Garcia\n"
"João Pedro\n"
"Vitor\n"
"maxiliamum LóPezz\n"
"Nadál\n"
"loriPsium PsisVõèrbizbbbbbbbbbb\n"
"Examples of non accepted string:\n\n"
"Jony Cam Vanis\n"
"9lucas P.us-kas1 Li1\n"
"What I tried:\n\n"
"^(?!.*?\\s{2})[A-Za-z ]{3,50}$\n"
"^([a-zA-Z][a-zA-Z]){3,50}$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.