re = /\b(\w+)\b\s*[-+\/*]\s*PrevYear\s*\1\b/m
str = 'Position_Name + PrevYear Position_Name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end