const regex = /(^|(?<=\s))(([A-Za-z\d]+)([_\.\-])?([A-Za-z\d]+))@([a-z]+([\.\-_][a-z]+)+)($|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|(?<=\\s))(([A-Za-z\\d]+)([_\\.\\-])?([A-Za-z\\d]+))@([a-z]+([\\.\\-_][a-z]+)+)($|)', 'gm')
const str = `Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. -- steve.parker@softuni.de.
Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information.
Please contact us at: support@github.com.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}