use strict;
my $str = 'Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. -- steve.parker@softuni.de.
Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information.
Please contact us at: support@github.com.';
my $regex = qr/(^|(?<=\s))(([A-Za-z\d]+)([_\.\-])?([A-Za-z\d]+))@([a-z]+([\.\-_][a-z]+)+)($|)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}