$re = '/\d{4}-\d{2}-\d{2}/m';
$str = '2021-12-07
2022-01-01
2021/01/01
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);