package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^-]+)\s*-\s*([^-]+) (\d+:\d+)`)
var str = `América - Cruz Azul 0:0
América - Cruz Azul 0:0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}