$re = '/([^-]+)\s*-\s*([^-]+) (\d+:\d+)/m';
$str = 'América - Cruz Azul 0:0
América - Cruz Azul 0:0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);