package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^#?([a-f0-9]{6}|[a-f0-9]{3})$`)
var str = `#000000
#ffffff
#fff
#12334t
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}