$re = '/^#?([a-f0-9]{6}|[a-f0-9]{3})$/mi';
$str = '#000000
#ffffff
#fff
#12334t
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);