#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?" & @CRLF & _
""
Local $sString = "frankp@gmail.com" & @CRLF & _
"shannon.eee@gmail.com" & @CRLF & _
"franks&shannon@gmail.com" & @CRLF & _
"frank%ddd@gmail.com" & @CRLF & _
"frank@gmail$.com" & @CRLF & _
"frank@gmail_gmail.com" & @CRLF & _
"frank@gmail.research.com" & @CRLF & _
"joe@ggg.gg.cccc.com" & @CRLF & _
"joe..joe@gmail.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/" & @CRLF & _
"https://stackoverflow.com/questions/5174171/fix-regular-expression-for-emails-to-not-allow-consecutive-periods/5174201#5174201" & @CRLF & _
"" & @CRLF & _
"*To avoid matching two consecutive dots you can add a negative lookahead at the beginning of your regular expression:" & @CRLF & _
"" & @CRLF & _
"/^(?!.*\.{2})[a-z0-9etc..." & @CRLF & _
" ------------" & @CRLF & _
"It will fail to match if there are two consecutive periods anywhere in the string and it doesn't require any other modifications to your original regular expression." & @CRLF & _
"" & @CRLF & _
"However it seems a bad idea as your regular expression isn't correct in the first place. If you insist on using regular expressions to validate email addresses, try this:" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"wilson..gmail.com" & @CRLF & _
"wilson.gmail.com" & @CRLF & _
"^(?!.*\.{2})/[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")