import re
regex = re.compile((r"[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\n"), flags=re.MULTILINE)
test_str = ("frankp@gmail.com\n"
"shannon.eee@gmail.com\n"
"franks&shannon@gmail.com\n"
"frank%ddd@gmail.com\n"
"frank@gmail$.com\n"
"frank@gmail_gmail.com\n"
"frank@gmail.research.com\n"
"joe@ggg.gg.cccc.com\n"
"joe..joe@gmail.com\n\n\n\n"
"/\n"
"https://stackoverflow.com/questions/5174171/fix-regular-expression-for-emails-to-not-allow-consecutive-periods/5174201#5174201\n\n"
"*To avoid matching two consecutive dots you can add a negative lookahead at the beginning of your regular expression:\n\n"
"/^(?!.*\\.{2})[a-z0-9etc...\n"
" ------------\n"
"It will fail to match if there are two consecutive periods anywhere in the string and it doesn't require any other modifications to your original regular expression.\n\n"
"However it seems a bad idea as your regular expression isn't correct in the first place. If you insist on using regular expressions to validate email addresses, try this:\n"
"*/\n\n"
"wilson..gmail.com\n"
"wilson.gmail.com\n"
"^(?!.*\\.{2})/[a-z0-9!#$%&'*+/=?^_`{|}~-]+(?:\\.[a-z0-9!#$%&'*+/=?^_`{|}~-]+)*@(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")