using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4})(\d{2})(\d{2})";
string substitution = @"$1-$2-$3";
string input = @"20210728";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}