// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{4})(\d{2})(\d{2})").unwrap();
let string = "20210728";
let substitution = "$1-$2-$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}