import re
regex = re.compile(r"([\w]+)[ \t]+=[ \t](Solver[ \t]*\(([\d.]+)[ \t]*,[ \t]*([\d.]+)[ \t]*,[ \t]*([\d.]+)[ \t]*\))\n\r?demo[ \t]*\(\1\.b[ \t]*,[ \t]*\1\.a[ \t]*,[ \t]*\1\.c[ \t]*\)", flags=re.MULTILINE)
test_str = ("import math\n\n"
"class Solver(object):\n"
" def __init__(self, a, b, c):\n"
" self.a = a\n"
" self.b = b\n"
" self.c = c\n\n\n"
"def demo(b, a, c):\n"
" d = b ** 2 - 4 * a * c\n"
" if d >= 0:\n"
" disc = math.sqrt(d)\n"
" root1 = (- b + disc) / (2 * a)\n"
" root2 = (- b - disc) / (2 * a)\n"
" print(root1, root2)\n"
" return root1, root2\n"
" else:\n"
" raise Exception\n\n\n"
"s = Solver(2, 123, 0.025)\n"
"demo(s.b, s.a, s.c)")
subst = "$2\\.demo()"
result = regex.sub(subst, test_str)
if result:
print(result)