#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\bsb\.(?:'s)?|\bsth\.|[\s'])(*SKIP)(*F)|."
Local $sString = "leave sb. alone" & @CRLF & _
"pick one's way forward" & @CRLF & _
"suffer from sth." & @CRLF & _
"and sb.'s way"
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)