$re = '/(?:\bsb\.(?:\'s)?|\bsth\.|[\s\'])(*SKIP)(*F)|./';
$str = 'leave sb. alone
pick one\'s way forward
suffer from sth.
and sb.\'s way';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;