package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,3}\.\d{1,2}`)
var str = `3.2
3.45
4.678
1235.887`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}