$re = '/\d{1,3}\.\d{1,2}/m';
$str = '3.2
3.45
4.678
1235.887';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);