package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^| )(\d*\.?\d+)`)
var str = `This is .34 meters of cable
.34 meters of cable
This is 0.34 meters of cable
0.34 meters of cable`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}