$re = '/(?:^| )(\d*\.?\d+)/m';
$str = 'This is .34 meters of cable
.34 meters of cable
This is 0.34 meters of cable
0.34 meters of cable';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);