import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "KW[^a-zA-Z1-9]*([1-9]+\\d*).*\\d+\\.\\d+\\.(\\d+).*";
final String string = "KW-7%C2%AD_12.02.-16.02.2018.pdf\n"
+ "KW-8_12.02.-16.02.2018.pdf\n"
+ "KW-03_12.02.-16.2.2018.pdf\n"
+ "KW-43_12.2.-06.02.2018.pdf\n"
+ "KW-43_12.2.2017-06.02.2018.pdf\n"
+ "KW-43_12.2.2017-06.02.2018-extra.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}