import Foundation
let pattern = #"KW[^a-zA-Z1-9]*([1-9]+\d*).*\d+\.\d+\.(\d+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
KW-7%C2%AD_12.02.-16.02.2018.pdf
KW-8_12.02.-16.02.2018.pdf
KW-03_12.02.-16.2.2018.pdf
KW-43_12.2.-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018.pdf
KW-43_12.2.2017-06.02.2018-extra.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)