package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([1-9]+\d*\.)+[1-9]+\d*)|[1-9]+\d*$`)
var str = `01`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}