$re = '/^(([1-9]+\d*\.)+[1-9]+\d*)|[1-9]+\d*$/A';
$str = '01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);