import re
regex = re.compile(r"[^{}[\]\n]", flags=re.MULTILINE)
test_str = ("{\n"
"\"help\": \"https://?name=package_search\", \n"
"\"success\": true,\n"
"\"result\": {\n"
" \"count\": 47, \n"
" \"facets\": {}, \n"
" \"results\": [\n"
" {\n"
" \"author\": \"ggm\",\n"
" \"author_email\": \"ggm@____.nl\",\n"
" \"creator_user_id\": \"x_x_x_x\" }]}}")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)