re = /(\(\d+), '(.*?)(?:[|]{3}.*?)?', (\d+\),?)/m
str = '(37, \'2011-01/1295144032_x_7cb0bcf1.jpg|||2011-01/1295266037_small_carterthal1.jpg.jpg|||2014-05/1401429739_3-fundamenta-vidyatshih2.jpg\', 66),
(38, \'2011-01/1295266433_event-image-poster.jpg|||2011-01/1295279508_16f7cb40.jpg\', 67),
(39, \'2012-01/1295277340_1.jpg|||2011-01/1295278172_08a9e04f4264-300x298.jpg|||2014-05/1401428634_vladislav-erko-castaneda-9.jpg\', 68),
(68, \'2011-03/1300177205_usui.jpg\', 393),
(37, \'upload/2011-01/1295144032_x_7cb0bcf1.jpg\', 66),
(38, \'upload/2011-01/1295266433_event-image-poster.jpg\', 67),
(39, \'upload/2012-01/1295277340_1.jpg\', 68),'
subst = '$1, \'upload/$2\', $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result