using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{3}-.{,5}";
string input = @"deleteABC-01234delete
deleteABC-012
failABC_012fail
BC-012fail";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}