re = /.{3}-.{,5}/
str = 'deleteABC-01234delete
deleteABC-012
failABC_012fail
BC-012fail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end