import re
regex = re.compile(r"(?<![;\{\}]|\*\/|\s*\/{2}.*?)$", flags=re.MULTILINE)
test_str = ("let app = nothing;\n"
"/* main function */\n"
"if (something) {\n"
" // this will be the eroor\n"
" const error = \"ough-ough!\"\n"
"}")
subst = ";"
result = regex.sub(subst, test_str)
if result:
print(result)