package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-5]?\d\W`)
var str = `12
35
78
8
678
60
80
0
1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}