$re = '/^[1-5]?\d\W/m';
$str = '12
35
78
8
678
60
80
0
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);