package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){(?<yourfield>.+)}`)
var str = `{{My_pa{ss}word}}
{{password}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}